Problemas na instalação do qtiplot  [Resolvido]

Reporte aqui dúvidas sobre aplicativos diversos, instalação e utilização.
Regras do fórum Leia as Regras Gerais do Chakra Brasil em "Normatividade" e pesquise antes de postar.
Se sua dúvida foi respondida, não esqueça de marcar RESOLVIDO em seus tópicos, botão com a marca verde Imagem

Problemas na instalação do qtiplot

Mensagempor marcos1977 » 19 Set 2012, 18:21  •  MS 1

Boa noite a todos. Estou com um problema com o qtiplot. A versao disponivel no ccr esta com problemas de dependencias (muparser), ja postei uma mensagem la. Porém, possuo a versao PRO, pois preciso de suporte a arquivos excel e origin, por causa dos meus estudos. O problema é o seguinte, normalmente esta versao PRO pode ser usada sem necessidade de compilar ou instalar. Ja testei no OpenSUSE e funciona legal. Porem, quando tento rodar o executavel pelo terminar recebo a seguinte mensagem:

[[email protected] qtiplot-0.9.9-rc2]$ qtiplot
bash: qtiplot: comando não encontrado


Verifiquei as permissoes e estao ok.

Alguma ideia?

Obrigado pela ajuda

  Mensagem da Moderação

!
O título do tópico foi editado para deixá-lo claro e objetivo aos leitores.

Holmes
Editado pela última vez por Holmes em 19 Set 2012, 19:21, em um total de 1 vez.
Razão: Edição do título.
Avatar do usuário
marcos1977
Simpatizante
 
Mensagens: 14
Registrado em: 19 Set 2012, 17:51
Agradeceu: 1 vez
Agradecido: 0 vez

Mensagempor Holmes » 19 Set 2012, 19:18  •  MS 2

oi marcos1977, vc já tentou usar o pacote da base AUR?

http://www.archlinux.org/packages/extra/x86_64/qtiplot/

pois no Chakra Linux também podemos usar os pacotes dessa base.

vlw fwi, Holmes :)

Note   De acordo com a regra n° 30, a mensagem foi editada pelo autor para adicionar um novo conteúdo!
Editado pela última vez por Holmes em 19 Set 2012, 19:29, em um total de 1 vez.
Razão: Adicionar o BBCode note.
Membro associado, Associação Software Livre

Visitem e colaborem com nosso Knowledge Base.

Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V Imagem.
Avatar do usuário
Holmes
Fundador
 
Mensagens: 1650
Artigos: 29
Registrado em: 05 Fev 2012, 20:40
Localização: Brasil
Agradeceu: 16 vez(es)
Agradecido: 106 vez(es)
Distro utilizada: Manjaro
Versão: 15.09
Ambiente: XFCE

Mensagempor Freax » 19 Set 2012, 20:07  •  MS 3

Olá Marcos

O pacote do ccr não instala devido a uma dependência não satisfeita muparser, esse pacote você pode instalar assim:

Código: Selecionar todos
wget http://www.chakra-linux.com.br/pkg/muparser-1.34-2-x86_64.pkg.tar.xz; sudo pacman -U muparser-1.34-2-x86_64.pkg.tar.xz


Após isso tente novamente instalar pelo ccr eu obtive êxito, como pode ver no print abaixo.

Image
Chakra Linux - Benz - KDE 4.10.1 - kernel 3.7.6-1-CHAKRA
Canal IRC Freenode Chakra Brasil
Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V
Chakra no Facebook | Chakra no Twitter
Avatar do usuário
Freax
Administrador
 
Mensagens: 320
Artigos: 5
Registrado em: 05 Fev 2012, 20:57
Localização: São Bernardo do Campo - SP
Agradeceu: 0 vez
Agradecido: 30 vez(es)
Distro utilizada: Chakra Benz
Versão: 2013.02

Mensagempor Holmes » 19 Set 2012, 21:15  •  MS 4

marcos1977, se você seguir a dica do Freax vai dar certo. ah! se solucionou o seu problema, por favor assinale a mensagem que te auxiliou nesse processo. para isto use o botão para dar por Resolvido, veja

Imagem

vlw fwi, Holmes :)
Membro associado, Associação Software Livre

Visitem e colaborem com nosso Knowledge Base.

Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V Imagem.
Avatar do usuário
Holmes
Fundador
 
Mensagens: 1650
Artigos: 29
Registrado em: 05 Fev 2012, 20:40
Localização: Brasil
Agradeceu: 16 vez(es)
Agradecido: 106 vez(es)
Distro utilizada: Manjaro
Versão: 15.09
Ambiente: XFCE

Mensagempor marcos1977 » 20 Set 2012, 06:57  •  MS 5

Obrigado a todos pela ajuda! Fiz como o Freak indicou e realmente funcionou. Porém, o problema desta versao é que ela nao da suporte a arquivos do origin ( e todo o meu trabalho esta neste formato).

Seguindo a dica do Holmes, encontrei no AUR do Arch o qtiplot com suporte a arquivos do Origin, por outro lado, existe outro problema com dependencia: desta vez o python2-pyqt. Seguindo a dica do Freax, tentei baixar e instalar este pacote, do repo do Arch. Nao sei se é possivel diretamente ou se é preciso converter o pacote antes?

Outra duvida. Como falei, tenho a versao PRO, que da suporte a arquivos excel, porém, quando tento lançar o arquivo pelo terminal aparece uma mensagem de arquivo nao encontrado. Usando o ./qtiplot & aparece o seguinte erro:

[[email protected] qtiplot-0.9.9-rc2]$ ./qtiplot &
[1] 2371
[[email protected] qtiplot-0.9.9-rc2]$ bash: ./qtiplot: Arquivo ou diretório não encontrado

[1]+ Fim da execução com status 127 ./qtiplot

O uso desta versao pouparia muito trabalho para a conversao dos arquivos que possuo!!!


Muito obrigado pela ajuda
Editado pela última vez por marcos1977 em 20 Set 2012, 07:22, em um total de 1 vez.
Razão: Informaçoes adicionais
Avatar do usuário
marcos1977
Simpatizante
 
Mensagens: 14
Registrado em: 19 Set 2012, 17:51
Agradeceu: 1 vez
Agradecido: 0 vez

Mensagempor Freax » 20 Set 2012, 12:14  •  MS 6

marcos1977 ,

Fico feliz que tenha funcionado, quanto a versão que possui notei que esta tentando executar direto como um binário ou script, essa sua versão não necessita instalar nada ? não exige qualquer dependência ? como usava ela em outras distros?

Referente a versão disponível no AUR aconselho você a solicitar também no fórum oficial do Chakra, em solicitações de pacotes pois o python2-pyqt tem dependências também, eu tentei por aqui mas quanto mais resolve mais aparece pacote que dependem de patch para funcionar.
Chakra Linux - Benz - KDE 4.10.1 - kernel 3.7.6-1-CHAKRA
Canal IRC Freenode Chakra Brasil
Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V
Chakra no Facebook | Chakra no Twitter
Avatar do usuário
Freax
Administrador
 
Mensagens: 320
Artigos: 5
Registrado em: 05 Fev 2012, 20:57
Localização: São Bernardo do Campo - SP
Agradeceu: 0 vez
Agradecido: 30 vez(es)
Distro utilizada: Chakra Benz
Versão: 2013.02

Mensagempor marcos1977 » 20 Set 2012, 12:45  •  MS 7

Obrigado epla ajuda Freax.

essa versao que possuo funcionou sem a instalaçao de nada. Como mencionei, no OpenSUSE apenas com dois cliques funcionou sem problemas. Testei no Arch tambem e funcionou apenas lançando do terminal (cd na pasta onde esta esta versao e lancei com o comando qtiplot). Nao sei se pode ser algum problema de permissao, mas aparentemente esta tudo certo.

Vou ver no forum do Chakra tambem.

Muito obrigado pela ajuda ate aqui!!!
Avatar do usuário
marcos1977
Simpatizante
 
Mensagens: 14
Registrado em: 19 Set 2012, 17:51
Agradeceu: 1 vez
Agradecido: 0 vez

Mensagempor Truta » 20 Set 2012, 12:56  •  MS 8

Como disse o Freax, você pode solicitar esse pacote no fórum oficial, aqui

http://chakra-project.org/bbs/viewforum.php?id=48

Truta
Imagem

[Dica] Antes de abrir um Novo Tópico, procure saber se a sua dúvida já foi respondida. Pesquise no Google por palavras (em inglês também) relacionadas à ela, somado à palavra "chakra".

Imagem Chakra Brasil planet

Imagem Canal IRC Freenode
Avatar do usuário
Truta
Colaborador
 
Mensagens: 648
Artigos: 3
Registrado em: 11 Fev 2012, 14:52
Localização: Brasil
Agradeceu: 32 vez(es)
Agradecido: 8 vez(es)
Distro utilizada: Chakra/Manjaro
Versão: Estável
Ambiente: KDE

  [Resolvido]

Mensagempor Freax » 21 Set 2012, 02:47  •  MS 9

Marcos,

Pedi ajuda no fórum oficial e me informaram que o python2-pyqt já esta em nosso repositório porem com o nome de pyqt.

Com essa informação em mãos e algumas horas tentando compilar... consegui fazer funcionar aqui, proceda com o comando abaixo:

Código: Selecionar todos
sudo pacman -S pyqt gsl; ccr --noedit -S tamu-anova; wget http://www.chakra-linux.com.br/pkg/qtiplot-opj-0.9.8.9-5-x86_64.pkg.tar.xz; sudo pacman -U qtiplot-opj-0.9.8.9-5-x86_64.pkg.tar.xz


Suporte Excel e Origin

Image

Lembrando que se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V
Chakra Linux - Benz - KDE 4.10.1 - kernel 3.7.6-1-CHAKRA
Canal IRC Freenode Chakra Brasil
Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V
Chakra no Facebook | Chakra no Twitter

Esta mensagem de Freax recebeu agradecimentos de
marcos1977 (22 Set 2012, 15:59)
Avatar do usuário
Freax
Administrador
 
Mensagens: 320
Artigos: 5
Registrado em: 05 Fev 2012, 20:57
Localização: São Bernardo do Campo - SP
Agradeceu: 0 vez
Agradecido: 30 vez(es)
Distro utilizada: Chakra Benz
Versão: 2013.02

Mensagempor Holmes » 21 Set 2012, 10:37  •  MS 10

olá Freax, muito boa essa resolução do problema postado por marcos1977 e agora acredito que vai dar certo para ele.

vlw fwi, Holmes :)
Membro associado, Associação Software Livre

Visitem e colaborem com nosso Knowledge Base.

Leia as Regras Gerais e pesquise antes de postar.
Se a sua dúvida foi respondida marque Resolvido em seu tópico com o botão V Imagem.
Avatar do usuário
Holmes
Fundador
 
Mensagens: 1650
Artigos: 29
Registrado em: 05 Fev 2012, 20:40
Localização: Brasil
Agradeceu: 16 vez(es)
Agradecido: 106 vez(es)
Distro utilizada: Manjaro
Versão: 15.09
Ambiente: XFCE

Próximo

Voltar para Aplicativos



Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante

cron
^ Voltar ao Topo